Simulación de memoria con PSeint

Vamos a simular una pequeña memoria de 2 palabras sin límite de ancho, usando PSeint. el Código es el siguiente.

Proceso memoria
//palabras de la memoria
palabra1<-“”;
palabra2<-“”;
Escribir “Introduzca operacion (E/L)”;
Leer operacion;
Si operacion=”E” Entonces
Escribir “Introduzca valor”
Leer valor;
Escribir “Introduzca posicion (1-2)”
Leer posicion;
Si posicion=1 Entonces
palabra1<-valor;
Sino
palabra2<-valor;
FinSi
Sino
Escribir “Introduzca posicion (1-2)”
Leer posicion;
Si posicion=1 Entonces
Escribir palabra1;
Sino
Escribir palabra2;
FinSi
FinSi
//——————Repetimos————————————————–
Escribir “Introduzca operacion (E/L)”;
Leer operacion;
Si operacion=”E” Entonces
Escribir “Introduzca valor”
Leer valor;
Escribir “Introduzca posicion (1-2)”
Leer posicion;
Si posicion=1 Entonces
palabra1<-valor;
Sino
palabra2<-valor;
FinSi
Sino
Escribir “Introduzca posicion (1-2)”
Leer posicion;
Si posicion=1 Entonces
Escribir palabra1;
Sino
Escribir palabra2;
FinSi
FinSi
FinProceso

Ejercicios

  1. Haz la traza con estos valores:
    1. Operación=E
    2. Valor=23
    3. Posición=1
    4. Operación=L
    5. Posición=1
    6. Salida=?????
  2. Modifica el programa para que solicite una instrucción nueva.
  3. Modifica el programa para que se pueda borrar el contenido de la memoria.
  4. Modifica el programa anterior para que solicite confirmación del borrado y antes de borrar muestre el contenido de la memoria.

Originally posted 2010-10-25 20:56:20.

Deja un comentario

Disculpa, debes iniciar sesión para escribir un comentario.