PSeint, un Pseudocompilador

Ya que vamos a escribir psudocódigo, necesitaremos un Pseudocompilador, por eso os presento, PSeint:

PSeInt es una herramienta para aprender la lógica de programación, orientada a estudiantes sin experiencia en dicha área. Mediante la utilización de un simple y limitado pseudo-lenguaje intuitivo y en español, permite comenzar a comprender conceptos básicos y fundamentales de un algoritmo computacional.

  • Descargar PSeint para windows de aquí.
  • Descargar PSeint para linux de aquí.
PSeint funcionando en Ubuntu

PSeint funcionando en Ubuntu

Ejemplos para PSeint

Ejemplo 1, calcular la media

// Calcula el promedio de una lista de N datos
Proceso Promedio
Escribir “Ingrese la cantidad de datos:”;
Leer n;
acum<-0;
Para i<-1 Hasta n Hacer
Escribir “Ingrese el dato “,i,”:”;
Leer dato;
acum<-acum+dato;
FinPara
prom<-acum/n;
Escribir “El promedio es: “,prom;
FinProceso
Ejemplo 1, adivinar un número
Proceso Adivina_Numero
intentos<-9;
num_secreto <- azar(100)+1;
Escribir “Adivine el numero (de 1 a 100):”;
Leer num_ingresado;
Mientras num_secreto<>num_ingresado & intentos>0 Hacer
Si num_secreto>num_ingresado Entonces
Escribir “Muy bajo”;
Sino
Escribir “Muy alto”;
FinSi
Escribir “Le quedan “,intentos,” intentos:”;
Leer num_ingresado;
intentos <- intentos-1;
FinMientras
Si intentos=0 Entonces
Escribir “El numero era: “,num_secreto;
Sino
Escribir “Exacto! Usted adivino en “,11-intentos,” intentos.”;
FinSi
FinProceso

Pitagoras

//    Lee los tres lados de un triangulo rectangulo, determina
// si corresponden (por Pitargoras) y en caso afirmativo
// calcula el area
Proceso TrianguloRectangulo
// cargar datos
Escribir “Ingrese el lado 1:”;
Leer l1;
Escribir “Ingrese el lado 2:”;
Leer l2;
Escribir “Ingrese el lado 3:”;
Leer l3;
// encontrar la hipotenusa (mayor lado)
Si l1>l2 Entonces
cat1<-l2;
Si l1>l3 Entonces
hip<-l1;
cat2<-l3;
Sino
hip<-l3;
cat2<-l1;
FinSi
Sino
cat1<-l1;
Si l2>l3 Entonces
hip<-l2;
cat2<-l3;
Sino
hip<-l3;
cat2<-l2;
FinSi
FinSi
// ver si cumple con Pitagoras
Si hip^2 = cat1^2 + cat2^2 Entonces // calcualar area
area<-(cat1*cat2)/2;
Escribir “El area es: “,area;
Sino
Escribir “No es un triangulo rectangulo.”;
FinSi
FinProceso
Más ejercicios en :pseint.sourceforge.net

Originally posted 2010-10-18 22:02:43.

2 Responses to “ PSeint, un Pseudocompilador ”

  1. bcn3098 dice:

    Buenas tardes Juan Luis,soy Feliciana,estoy mirando el ejemplo de pseint sobre “cálculo de media” y con la expresión “acum” no sé a que te refieres.Gracias.

Deja un comentario

Disculpa, debes iniciar sesión para escribir un comentario.