Manual resumido para PSeint [1ª parte]

Características

  • Herramientas de edición básicas en español
  • Presenta ayudas para la escritura
  • Puede ejecutar los algoritmos escritos
  • Permite ejecutar el algoritmo paso a paso
  • Determina y marca los errores de sintaxis y en tiempo de ejecucion
  • Genera diagramas de flujo a partir del algoritmo escrito
  • Convierte el algoritmo de pseudocodigo a codigo C++
  • Es totalmente libre y gratuito (licencia GPL)

El pseudocódigo

  • Sintaxis sencilla
  • Manejo de las estructuras básicas de control
  • Solo 3 tipos de datos básicos: numérico, caracter  y lógico (verdadero-falso).
  • Estructuras de datos: array

Apariencia

Proceso Nombre
accion 1;
accion 1;
.
.
.
accion n;
FinProceso

Primeras instrucciones

  1. Asignación : a<- 5;
  2. Lectura: Leer variable;
  3. Escritura: Escribir “Hola”;
  4. Operaciones
    1. a<-3+3;
    2. b<-a-2;
    3. c<-a*b;
    4. ….

Condiciones

Si <condición>
Entonces
<instrucciones>
Sino
<instrucciones>
FinSi

Originally posted 2010-10-19 20:53:47.

Deja un comentario

Disculpa, debes iniciar sesión para escribir un comentario.