Las morcillas de Burgos

Un Pequeño comercio de Villanueva de la Serena ha comenzado ha vender morcillas de Burgos. Desea controlar al máximo el proceso de compra/venta de morcillas. Para ello seguirá estos pasos.

  • La morcillas se compran por unidad y se venden de la misma manera, de tal forma que si queremos comprar dos morcilla deberemos hacer el procesos dos veces. Todas las morcillas compradas son de las mismas características y mismo precio. A la hora de vender no tenemos que buscar ninguan morcilla simplemente vendemos la última que llego.
  • En encargado desea saber en todo momento, cuantas morcillas compradas tenemos y cuantas vendidas
  • Una misma morcilla sólo se puede comprar y vender una vez, es decir, una vez que se compra una morcilla no puede volver a comprarse.

Posible Codificación para la solución

Proceso morcillas
dimension morcillas[10];
dimension morcillas_vendidas[100];
Para i<-1 Hasta 10 Hacer
morcillas[i]<-“Vacio”;
FinPara
Para i<-1 Hasta 100 Hacer
morcillas_vendidas[i]<-“Vacio”;
FinPara
repetida<-0;
i_morcillas<-0;
i_vendidas<-0;
salir<-0;
morcilla<-“Vacio”;
opt<-1;
Mientras salir=0 Hacer
Escribir “1.-Comprar morcilla”;
Escribir “2.-Contar morcillas”;
Escribir “3.-Vender morcilla”;
Escribir “4.-Generar Stock”;
Escribir “5.-Salir”;
Leer opt;
Segun opt Hacer
1:
repetida<-0;
Leer morcilla;
Para i<-1 Hasta i_morcillas Hacer
Si morcilla=morcillas[i] Entonces
Escribir “Morcilla repetida, vuelva a introducir”;
repetida<-1;
FinSi
FinPara
Para i<-1 Hasta i_vendidas Hacer
Si morcilla=morcillas_vendidas[i] Entonces
Escribir “Morcilla vendida, vuelva a introducir”;
repetida<-1;
FinSi
FinPara
Si repetida=0 Entonces
i_morcillas<-i_morcillas+1;
morcillas[i_morcillas]<-morcilla;
FinSi
2:
Escribir “Tiene usted: “,i_morcillas,” morcilla/s”;
3:
Si i_morcillas>=1 Entonces
Escribir “Va a vender usted la morcilla: “, morcillas[i_morcillas];
i_vendidas<-i_vendidas+1;
morcillas_vendidas[i_vendidas]<-morcillas[i_morcillas];
i_morcillas<-i_morcillas-1;
Sino
Escribir “No tiene morcillas, por favor compre para seguir vendiendo”;
FinSi
4:
Escribir “Tiene usted las siguientes morcillas:”;
Para i<-1 Hasta i_morcillas Hacer
Escribir morcillas[i];
FinPara
Escribir “Ha vendido usted las siguientes morcillas:”;
Para i<-1 Hasta i_vendidas Hacer
Escribir morcillas_vendidas[i];
FinPara
5:
salir<-1;
De Otro Modo:
Escribir “Opción no valida”
FinSegun
FinMientras
FinProceso

Ejercicio Adicionales

  1. Modifícalo para que se puedan comprar las morcillas de dos en dos, o de cuatro en cuatro….
  2. Modifícalo para que se puedan vender las morcillas de dos en dos, o de cuatro en cuatro….
  3. Si cada morcilla me cuesta 2 € y las vendo por 5 €. Queremos saber en el Stock cuanto llevo ganado o perdido.
  4. Vuelve a hacer el diseño con estás modificaciones.

4 Responses to “ Las morcillas de Burgos ”

  1. bcn3098 dice:

    Buenos días,juan luis.¿te importarìa hacer el primes ejercicio
    del examen?quiero ver como se hace el duplicado en una matriz.Gracias

    • admin dice:

      En ese ejercicio no tenemos que hacer ningún duplicado de matriz, simplemente tenemos que insertar sin duplicados igual que en los ejercicios de clase.
      En el PDF de operaciones básicas con vectores tienes un insertar sin duplicados. No obstante te pongo aquí el trozo de código que inserta sin duplicados para ese ejercicio:

      ….
      duplicado< -0; Escribir "Dígame el DNI del cliente a insertar"; Leer dni; Para i<-0 hasta 15 Hacer Si trabajadores[i,3]=dni Entonces //el DNI está en la posición 3 duplicado<-1; Escribir "Trabajador ya existente"; FinSi FinPara Si duplicado=0 Entonces Escribir "Teclee el nombre del trabajador"; Leer trabajadores[i_trabajadores,1]; Escribir "Teclee el teléfono del trabajador"; Leer trabajadores[i_trabajadores,2]; trabajadores[i_trabajadores,3]<-dni i_trabajadores<-i_trabajadores+1; //incremento el índice FinSi ....

Deja un comentario

Disculpa, debes iniciar sesión para escribir un comentario.