La quesería simplificada

Para a los que ayer se os hacía muy grande el problema de la quesería, vamos a hacerlo por partes, haremos el ejercicio igual pero con un poco menos de control sobre las entradas y sin la opción de vender, con lo cual queda muy simplificado el generar el Stock.

Código

Proceso Queseria
//Estructuras de datos
Dimension producidos[50];
Dimension aptos[50];
//Variables de trabajo
valor<-0;
j<-1;
i_producidos<-1;        //Aquíllevo la las posiciones de uso de la lista
i_aptos<-1;
//Iniciar los tableros
Para i<-1 hasta 50 Hacer
producidos[i]<-“vacio”;
aptos[i]<-“vacio”;
FinPara
Mientras valor<4  Hacer
//Menú del programa
Escribir “Seleccione una opcion:”;
Escribir “1. Añadir queso producido”;
Escribir “2. Añadir queso apto”;
Escribir “3. Generar Stock”
Escribir “4. Salir”;
Leer valor;
//Interpretación de las órdenes
Segun valor Hacer
1:
Escribir “Meta el nombre del queso producido”                                          //Opciones del programa
Leer producidos[i_producidos];
i_producidos<-i_producidos+1;
2:
Escribir “Diga que queso producido es apto”
Para j<-1 hasta i_producidos-1 Hacer
Escribir producidos[j];
FinPara
Leer aptos[i_aptos];
i_aptos<-i_aptos+1;
3:
Escribir “Tenemos estos quesos disponibles:”;
Para i<-1 hasta i_aptos-1 Hacer
Escribir aptos[i];
FinPara
4:
Escribir “Hasta otra”;
De Otro Modo:
Escribir “Opción no valida”;
FinSegun
FinMientras
FinProceso

Ejercicios

  1. Cuenta el número de disponibles que tenemos, en la opción Stock
  2. Impide la inserción de duplicados.
  3. Añade la lista de vendidos
  4. Haz el Stock descontando los vendidos.

Deja un comentario

Disculpa, debes iniciar sesión para escribir un comentario.