Bucle para y vectores

Estudia los siguientes algoritmos:

Proceso vector1
Dimension vector [3];
Escribir “valor 1:”;
Leer vector[1];
Escribir “valor 2:”;
Leer vector[2];
Escribir “valor 3:”;
Leer vector[3];
Para i<-1 Hasta 3 Con Paso 1 Hacer
Escribir vector[i];
FinPara
FinProceso

Ejercicios

  1. Modifica el ejemplo para que lea los valores del vector con un bucle para
  2. Modifica el ejemplo para que el vector sea de 10 posiciones
  3. ¿Puedes hacerlo de 200 posiciones y que se rellene sólo?

Proceso vector2d

Dimension vector [2,2];

Escribir “valor 1 1:”;

Leer vector[1,1];

Escribir “valor 1 2:”;

Leer vector[1,2];

Escribir “valor 2 1:”;

Leer vector[2,1];

Escribir “valor 2 2:”;

Leer vector[2,2];

Para i<-1 Hasta 2 Con Paso 1 Hacer

Para x<-1 Hasta 2 Con Paso 1 Hacer

Escribir vector[i,x];

FinPara

FinPara

FinProceso

Ejercicios

  1. Modifica el ejemplo para que lea los valores del vector con un bucle para
  2. Modifica el ejemplo para que el vector sea de 10 posiciones
  3. ¿Puedes hacerlo de 200 posiciones y que se rellene sólo?

Ordenaciones

Proceso ordenar

Dimension vector [4];

Escribir “valor 1 “;

Leer vector[1];

Escribir “valor 2:”;

Leer vector[2];

Escribir “valor 3:”;

Leer vector[3];

Escribir “valor 4:”;

Leer vector[4];

Para i<-1 Hasta 4 Con Paso 1 Hacer

Para x<-1 Hasta 4 Con Paso 1 Hacer

Si vector[i]>vector[x] Entonces

aux<-vector[i];

vector[i]<-vector[x];

vector[x]<-aux;

FinSi

FinPara

FinPara

Para i<-1 Hasta 4 Con Paso 1 Hacer

Escribir vector[i];

FinPara

FinProceso

2 Responses to “ Bucle para y vectores ”

  1. Alberto dice:

    En un vector de 2d como le pido al usuario que introduzca los valores? mi duda es que el los vectores de 1d le solicito i pero en los de 2d como tengo i,x no se como tengo que solicitarlos.

    • admin dice:

      Buenas noches:

      Para pedirle los valores al usuario, debes hacer igual que con uno de una dimensión, sólo que te harán falta dos índices, la parte de dentro de los “Para ” te quedaría algo así:

      ….
      Escribir “Introduce valor:”;
      Leer vector[i,j]; //Siendo i y j los índices de los bucles para.
      …..

      Espero que te sirva.

Deja un comentario

Disculpa, debes iniciar sesión para escribir un comentario.