Prácticas de Analisis

Descargar (PDF, 111KB)

Descargar (PDF, 57KB)

Una posible solución para el simulador de ficheros

Proceso ficheros

dimension fichero[10,2];

Para i<-1 hasta 10 Hacer

Para j<-1 hasta 2 Hacer

fichero[i,j]<-0;

FinPara

FinPara

aux<-0;

linea<-1;

salir<-0;

opt<-1;

mientras salir=0 hacer

Escribir “1 rellenar fichero del todo”;

Escribir “2 rellenar por líneas”;

Escribir “3 Borrar líneas”;

Escribir “4 Borrra todo”;

Escribir “5 Compactar”;

Escribir “6 Mostrar”;

Escribir “7 Salir”;

Leer opt;

Segun opt Hacer

1:

Para i<-1 hasta 10 Hacer

fichero[i,1]<-i;

Leer fichero [i,2];

FinPara

2:

Fichero[linea,1]<-linea;

Leer fichero [linea,2];

linea<-linea+1;

3:

Escribir “Que linea desea borrar”;

Leer linea_borrar;

fichero [linea_borrar,2]<-0;

4:

Para i<-1 hasta 10 Hacer

Para j<-2 hasta 2 Hacer

fichero[i,j]<-0;

FinPara

FinPara

linea<-1;

5:

Para i<-1 hasta 10 Hacer

Para j<-1 hasta 10 Hacer

si fichero[i,2]>fichero[j,2] Entonces

aux<-fichero[i,2];

fichero[i,2]<-fichero[j,2];

fichero[j,2]<-aux;

finsi

FinPara

Finpara

6:

Para i<-1 hasta 10 Hacer

Escribir fichero[i,1],” “,fichero[i,2];

FinPara

7:

salir<-1;

De Otro Modo:

Escribir “Error”;

FinSegun

finmientras

FinProceso

2 Responses to “ Prácticas de Analisis ”

  1. bcn3098 dice:

    Proceso cliente
    dimension cliente[3,2];
    para i<-1 hasta 3 Hacer
    para j<-1 hasta 2 Hacer
    cliente[i,j]<-"vacio";

    FinPara
    FinPara
    valor<-0;
    i<-1;
    j<-1;

    mientras valor<4 Hacer
    Escribir "seleccionar opcion";

    Escribir "1.insertar cliente";
    escribir "2.generar listado";
    escribir "3.salir";
    leer valor;
    Segun valor Hacer
    1:
    escribir "introducir cliente:nombre_apellido_dni";
    para i<-1 hasta 3 con paso 1 Hacer
    para j<-1 hasta 2 con paso 1 Hacer

    escribir cliente[i,j];
    leer cliente[i,j];
    FinPara
    finpara

    2:
    escribir "en lista tenemos estos clientes";
    para i<-1 hasta 3 con paso 1 Hacer
    para j<-1 hasta 2 con paso 1 Hacer

    escribir cliente[i,j];
    leer cliente[i,j];
    FinPara
    FinPara
    3:
    escribir "hasta otra"
    FinSegun
    FinMientras
    finproceso

    juan luis,ahi te mando el ejercicio de cliente dime dónde estan los fallos

  2. bcn3098 dice:

    Creo que lo he solucionado, me da más o menos lo que queremos.Mañana te lo enseño para ver que tal.Hasta mañana

Deja un comentario

Disculpa, debes iniciar sesión para escribir un comentario.