Ejercicios pseudocódigo

Ejercicios con Variables

  1. Leer una secuencia de 5 números y mostrar la suma de los pares.
Proceso iguales
suma<-0;
Escribir “Introduzca 5 numeros: “;
Leer n1,n2,n3,n4,n5;
Si n1 mod 2=0 Entonces
suma<-n1+suma;
FinSi
Si n2 mod 2=0 Entonces
suma<-n2+suma;
FinSi
Si n3 mod 2=0 Entonces
suma<-n3+suma;
FinSi
Si n4 mod 2=0 Entonces
suma<-n4+suma;
FinSi
Si n5 mod 2=0 Entonces
suma<-n5+suma;
FinSi
Escribir “La suma de los pares es: “, suma;
FinProceso
  1. Leer una secuencia de 5 números y determinar el mayor de los pares leídos.
  2. Leer una secuencia de 5 números y mostrar el mayor de los múltiplos de 5 leídos y el menor de los múltiplos de 3 leídos.

Ejercicios con Vectores o Arrays

  1. Dado un vector de 5 enteros actualizar cada posición de dicho vector con un número leído.
  2. Leer una secuencia de 20 números almacenarlos en un vector y mostrar la posición donde se encuentra el mayor valor leído.
  3. Dado dos vectores A y B de 15 elementos cada uno, obtener un vector C donde la posición i se almacene la suma de A[i]+B[i].
  4. Dado dos vectores A y B de 15 elementos cada uno, obtener un vector C donde la posición i se almacene la suma de A[i]+B[i] y mostrar el mayor de los C[i].
  5. Dado una secuencia de número leídos y almacenados en un vector A mostrar dichos números en orden.
  6. Dado una secuencia de número leídos y almacenados en un vector A y un número leído determinar si dicho número se encuentra o no en el vector.
  7. Leer 20 números y almacenarlos de manera ordenada en un vector.
  8. Dado dos matrices A y B obtener la suma.
  9. Dado una matriz determinar la posición (i,j) del mayor.
  10. Dado una matriz determinar la posición (i,j) del mayor y menor.
  11. Leer una secuencia de 20 números almacenarlos en un vector A[1..20] y mostrar la suma de los elementos que ocupan posiciones pares y el mayor de los que ocupan posiciones impares.
  12. Dado un vector de números determina aquellos que sean primos.

Originally posted 2010-10-19 21:17:21.

2 Responses to “ Ejercicios pseudocódigo ”

  1. fernando dice:

    hola juan luis me he conectado desde mi pc en el pueblo y estoy mirando el blog y buscando adónde hasinstalado las correcciones de los ejercicios del viernessi pudieras poner por ejemplo todos los ejercicios corregidosen un mismo lugar sería para mí personalmente más fácil, de este modo perdería así ya menos tiempo en hacer estas búsquedas (lo mismo para los ejercicios que se deban hacer)gracias y espero poder encontrar ahora tu respuestafernando

Deja un comentario

Disculpa, debes iniciar sesión para escribir un comentario.